Page 1 of 1

March madness [FIXED, v1.0.7]

Posted: Fri Apr 06, 2007 11:29 am
by Venger
Ok, I went over to my buddies house with my laptop network to show off the latest ver of BRPG

We experienced an unexpected phenomena (bug), and I dont know quite how to explain it so I will just tell what we experienced

Here are the parameters
Peer to Peer network with two laptops

The GM laptop Dell Inspirion 8600, 1ghz, 1gb ram
The Playar laptop is a Dell Inspiron 8100, 1ghz, 512 MB Ram

BRPG ver 106b

FoW - On

One (1) Token with standard torch light source

Map.. 1024x768, 1.6mb JPG image, black & white floor plan

After setting the "table" my friend moved his token from one "room" on the map to another.

The GM client updated immediatly and I saw where his char moved to, and all things seemed normal including FoW and lighting.

At first, the player client didnt update. Then his token began to "creep" towards the destination. But, it didnt seem to move in a straight line towards the destination.

Then his token jumed to the destination, and then on it's own, slid back to the origin.
This happened repeatedly

During this time he tried to move his token back to the starting hex.
The Gm client sort of lost track of the token for a few moments, and the token sort of decided that it was just going to sort of scoot around all over the place, in places where we had not moved to.

So after rebooting the laptops and trying again, the second go round didnt fare much better than the initial go round, same things happened more or less, but the bottom line was, the token wouldnt go to its destination, and would just sort of "march" around wherever it wanted.

We wrestled with BRPG for a couple hours trying various things, sometimes it would cooperate, sometimes not. It was as if the token were "possessed" by spirits of unknown origin

This was all very strange and disconcerting, and Since we were trying to play a Call of Cthulhu game, we decided to call it a night before we manifested something dire *chuckling somewhat insanely*

BTW- Happy Easter to all

Posted: Fri Apr 06, 2007 1:58 pm
by heruca
This sounds like the dreaded "dancing figure" bug introduced in v1.0.6b. It happens if FoW is on and you have the Character Name label turned on and no notes attached to the unit. Workaround: add notes to the figure, or turn off the Character Name label.

Read the bottom half of this page, so that you can confirm if this is the same issue that affected your game: ... 8&start=30

Posted: Fri Apr 06, 2007 2:42 pm
by Venger
ahhhh looks familiar. I will try it sometime this weekend and see if the workaround helps

Posted: Tue Apr 17, 2007 3:02 am
by heruca
Is this fixed in v1.0.7? It should be, but I always prefer it when someone else confirms it for me.

Posted: Tue Apr 17, 2007 12:08 pm
by Venger
Ok I havent had a chance to review 107 but will make an effort to do so this evening and report back

Posted: Wed Apr 18, 2007 10:14 am
by Venger
I ran a few tests, and it appears this is fixed

no issue regarding odd behaviours