Accessing Reference Material [FIXED-v1.0.7a]

An archive for tracking bugs that have already been fixed
Locked
User avatar
tdwyer11b
Captain
Posts: 65
Joined: Tue Aug 15, 2006 1:21 pm

Accessing Reference Material [FIXED-v1.0.7a]

Post by tdwyer11b » Tue Apr 10, 2007 2:31 am

Was wondering if anyone else was experiencing this. When I send audio (music) then consult the library, I get a play preview icon in place of the thumbnail for the reference material. Clicking cancel does cancel the music, but I'm unable to get to any of my reference material while aucio is being played.

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Tue Apr 10, 2007 9:53 am

Ooh...that's probably an old bug that's never been reported before, since I haven't messed with either audio or the Library feature in a while.

Thanks for reporting it. I'll see if I can reproduce it. Might be an easy fix.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Tue Apr 10, 2007 1:09 pm

Bug confirmed. Preview thumbnails aren't being shown except for at the "Unfiled" directory level (and even then it sometimes fails). For the record, this bug is completely unrelated to playing audio, it's just that the audio preview icon lives on the same screen, but is normally hidden while an image thumbnail preview is being shown.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
tdwyer11b
Captain
Posts: 65
Joined: Tue Aug 15, 2006 1:21 pm

Post by tdwyer11b » Tue Apr 10, 2007 3:02 pm

Right on, just making sure it wasn't just me ;)

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Mon Apr 16, 2007 9:38 pm

This is fixed for v1.0.7a.

Great catch, tdwyer11b. It took me over an hour to track down the bug. Turns out it only manifests if you first go to the Audio panel, and then go straight to the Library browser without first going to some other panel that shows image thumbnail previews.

So that's the workaround in v1.0.7: from the Audio panel, press either the [M] or [V] hotkey (which forces an image thumbnail preview), then press the [L] hotkey.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Locked

Who is online

Users browsing this forum: No registered users and 4 guests