Die roll modifier not being applied first roll from figures

An archive for tracking bugs that have already been fixed
User avatar
Kazander
General
Posts: 367
Joined: Sat Feb 23, 2008 7:51 pm

Die roll modifier not being applied first roll from figures

Post by Kazander » Fri Dec 26, 2008 7:26 pm

If I have a die roll macro like 4d6-3 saved with a token, save the encounter, close BRPG, re-open BRPG and the encounter, then the first time a die roll using a modifier for a given figure is rolled, then the modifier is not being applied.

If BRPG is not closed/reopened, the bug does not appear. The bug only seems to happen once per figure. If that same figure has several die macros with die roll modifiers, then the bug only seems to appear the first time per figure, not the first time per macro.

User avatar
heruca
Developer
Posts: 9323
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Mon Feb 02, 2009 12:13 am

This appears to be fixed in v1.4a. Please confirm when you get a chance, as this bug was sometimes difficult for me to replicate even in v1.3f and v1.4.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Kazander
General
Posts: 367
Joined: Sat Feb 23, 2008 7:51 pm

Post by Kazander » Sat Mar 21, 2009 1:43 pm

It would appear that this problem is only 'mostly' fixed as of 1.4e.

Now instead of happening once per figure per session, it only appears to happen once per session, on the first die roll that uses a modifier, when loaded from the context menu on the figure. If loaded from the Dice Macro window, it's fine. But the first one with a Modifier doesn't load properly (i.e. a macro that's 3d6+3 only loads as 3d6 the first time. Second time it comes up as 3d6+3 properly).

Also, it does not apply to the GM rolling for GM-owned figures, only the GM rolling for figures owned by player clients or "everyone", or players rolling for their own figures or figures owned by "everyone".

User avatar
heruca
Developer
Posts: 9323
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sat Mar 21, 2009 1:55 pm

Great job outlining the details of what triggers this bug! That should make it much easier for me to find and fix.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Locked