Die roll modifier not being applied first roll from figures

An archive for tracking bugs that have already been fixed
User avatar
Kazander
General
Posts: 367
Joined: Sat Feb 23, 2008 7:51 pm

Die roll modifier not being applied first roll from figures

Post by Kazander » Wed Jun 24, 2009 8:14 pm

The bug I first posted here (Die roll modifier not being applied first roll from figures) hasn't quite been stomped out yet.

If you have a figure with a context menu die roll that has both a total die roll modifier and a 2nd die type, the bug manifests itself still. The macro has to be loaded through Dice Macro window, or shift-run from the context menu (failing to run directly, and not even loading properly), attempted to run (failing because the modifier will be missing), and then shift-run from the context menu a second time before it will work properly.

Loading or running from the context menu the first time does not function correctly.

Edit: edited subject line to include latest versions of BRPG.
Last edited by Kazander on Sun Nov 08, 2009 8:00 pm, edited 1 time in total.

User avatar
Kazander
General
Posts: 367
Joined: Sat Feb 23, 2008 7:51 pm

Post by Kazander » Tue Nov 03, 2009 1:03 am

Just an update that you probably know of since this bug hasn't been declared "fixed", is that it appears to still be present in 1.4L.

User avatar
heruca
Developer
Posts: 9323
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sat Dec 19, 2009 8:59 am

I think I may have fixed this bug for v1.5a.

Does this bug occur for you in v1.5 if the dice macro is attached to an object instead of a figure?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Kazander
General
Posts: 367
Joined: Sat Feb 23, 2008 7:51 pm

Post by Kazander » Sat Dec 19, 2009 12:59 pm

Hmmm. This is interesting. Actually I get no difference between Objects and Figures.

What I do get is a difference between updated Deployments and Encounters from previous versions, and brand new Deployments and Encounters.

Updated ones exhibit the same problem as previously.

New ones appear to work fine with respect to die modifiers.

I did have a problem in one of my tests this morning where they all wanted to apply the die roll to a field in TS (sorry I didn't copy the message), but I haven't been able to recreate it after a restart of BRPG.

User avatar
Kazander
General
Posts: 367
Joined: Sat Feb 23, 2008 7:51 pm

Post by Kazander » Tue May 25, 2010 8:01 pm

Confirmed fixed in 1.6c.

Locked