Page 1 of 1

Random Freezing, Object/Figure Rotation (?)

Posted: Sat Jun 27, 2009 2:25 am
by nightwalker450
The program sometimes stop responding completely. I can't figure out what is causing it exactly, but it seems to be when I use the mousewheel to rotate a figure or an object.

Could this be related to preventing portrait tokens from rotating? But its happened with objects, and with free floating objects as well.

If I can get it to reliably happen I'll report back with more.

Ok, maybe it seems to be doing it rather reliably just by putting down an object and trying to rotate it. Sometimes it'll rotate partially, sometimes it freezes up.

I'm doing this while not connected, could it be the better updating speed when connected might be causing an issue?

Posted: Sat Jun 27, 2009 2:50 am
by heruca
This is with v1.4g, I gather? I'll look into it. Sounds like it's getting stuck in an endless loop for some reason.

Posted: Thu Jul 02, 2009 8:31 pm
by nightwalker450
Still happening in 1.4h.

I just opened a fresh Battlegrounds.

Placed a Human Skull, ok.

Then tried to use the Mousewheel to rotate, and it locked up.

Posted: Thu Jul 02, 2009 9:23 pm
by Omnidon
Ran into this one too, 1.4h

Posted: Thu Jul 02, 2009 10:00 pm
by heruca
Always with the mousewheel, or does it also happen with the rotation hotkeys?

Posted: Thu Jul 02, 2009 10:05 pm
by Omnidon
Only crashes with the mousewheel. However, if you press the hotkeys repeatedly, it will queue up the rotations and won't let you do anything else until it finishes cycling through the rotations invoked by every single keypress.

Posted: Sun Jul 05, 2009 12:08 am
by nightwalker450
Good news is it only locks up the player who does it... So as long as the GM doesn't do it, should be fine.

My group should be fine as long as the GM doesn't, since everyone else uses Laptops, so no scroll wheels.

Posted: Sun Jul 05, 2009 12:36 am
by heruca
That info gives me a very good idea of where to look for the problem.

Posted: Mon Jul 06, 2009 4:01 pm
by heruca
Bug confirmed. It appears to only affect Windows systems, and is caused by an "endless loop". I'm working on a fix right now.

Posted: Mon Jul 06, 2009 6:30 pm
by heruca
This is fixed for v1.4i.

Posted: Tue Jul 07, 2009 4:11 am
by Spyke
Excellent. Thanks.

Spyke

Posted: Tue Jul 07, 2009 2:29 pm
by Omnidon
Omnidon wrote:if you press the hotkeys repeatedly, it will queue up the rotations and won't let you do anything else until it finishes cycling through the rotations invoked by every single keypress.
Any chance of a fix or workaround for that usability issue? Maybe set a max number of queued rotations? After all, there's no point in rotating something 360° or more.

Posted: Tue Jul 07, 2009 3:26 pm
by heruca
In v1.4i, I am now flushing keyboard events that were received while the unit rotation was taking place.

Posted: Sun Jul 12, 2009 2:22 pm
by nightwalker450
Confirmed Fixed.