Director Player Error [FIXED]

An archive for tracking bugs that have already been fixed
Locked
Farland
High Commander
Posts: 530
Joined: Sun Apr 23, 2006 4:38 pm
Contact:

Director Player Error [FIXED]

Post by Farland » Thu Nov 30, 2006 12:52 am

So today when testing the new version, every time I place a figure-- any figure-- I get a Director Player Error:

"List Expected for Handler
# count
Script Error. Continue?"

I click yes and it seems to work fine, but still the error is there every time.
The World of Farland: www.farlandworld.com

The best PbP site on the net: www.myth-weavers.com

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Nov 30, 2006 1:23 am

Did deploying figures work initially and then the error started happening every time, or did it never work right? Is this in solo mode, or with other clients connected?

Are you sure you installed into a fresh directory, and not over your old one? I've been deploying figures all day in v1.0.2 without a hitch. On both a Mac and a PC.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Farland
High Commander
Posts: 530
Joined: Sun Apr 23, 2006 4:38 pm
Contact:

Post by Farland » Thu Nov 30, 2006 7:45 pm

It happens no matter whether I am connected to a client or not.

As for "installing"... well that confused me a bit. I do not see any exe file or installer. All I do is unzip to a directory and run it from there.

I had the old version in a folder in program files called BRPG. I deleted the old folder and all the files in it, and then I created a new folder of the same name in the same place and unzipped the new BRPG version there.

Am I doing something wrong?

I actually am computer-literate, believe it or not. :)
The World of Farland: www.farlandworld.com

The best PbP site on the net: www.myth-weavers.com

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Nov 30, 2006 7:51 pm

Hmm, sounds like you're "installing it" correctly. I assume you have full read/write permissions to that part of the hard drive? Try re-downloading the zip, in case something got corrupted the first time.

Is anyone else getting this error when deploying figures in v1.0.2?

Edit: Do you have another computer you could try this on, too? If it works on one, at least you'll know it's not BRPG that's broken, and is simply some sort of configuration issue.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Farland
High Commander
Posts: 530
Joined: Sun Apr 23, 2006 4:38 pm
Contact:

Post by Farland » Thu Nov 30, 2006 8:26 pm

Well, the issue does not occur on my player's laptop, so maybe it is a config issue on my comp. I'll try reinstalling.
The World of Farland: www.farlandworld.com

The best PbP site on the net: www.myth-weavers.com

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Nov 30, 2006 8:45 pm

If that doesn't work, try deleting your invisible prefs files (userpref.txt, userprefs2.txt).

On Windows, Prefs are stored in this location, in an invisible folder:
C:\Documents and Settings\yourAccountName\Application Data\Macromedia\Director MX 2004\Battlegrounds RPG Edition\Prefs
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Fri Dec 01, 2006 7:40 am

To reveal hidden folders in Windows, go to Tools --> Folder Options --> View Tab --> Show Hidden Files & Folders

That, however, should not be necessary if you use a direct file path like heruca posted.

C:\Documents and Settings\yourAccountName\Application Data\Macromedia\Director MX 2004\Battlegrounds RPG Edition\Prefs

Don't forget to change it to your account name though.

Farland
High Commander
Posts: 530
Joined: Sun Apr 23, 2006 4:38 pm
Contact:

Post by Farland » Fri Dec 01, 2006 10:24 am

:shock:

Damn, guys, cut me some slack here. I DO know how to reveal hidden files and folders in windows. I really am not too bad with a computer.

:D
The World of Farland: www.farlandworld.com

The best PbP site on the net: www.myth-weavers.com

Farland
High Commander
Posts: 530
Joined: Sun Apr 23, 2006 4:38 pm
Contact:

Post by Farland » Fri Dec 01, 2006 6:04 pm

Okay, I redownloaded and reinstalled and the problem is fixed.
The World of Farland: www.farlandworld.com

The best PbP site on the net: www.myth-weavers.com

User avatar
heruca
Developer
Posts: 9382
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Dec 01, 2006 6:14 pm

I'm very happy to hear that.

So, do we chalk this up to a corrupted download, then?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Farland
High Commander
Posts: 530
Joined: Sun Apr 23, 2006 4:38 pm
Contact:

Post by Farland » Fri Dec 01, 2006 7:13 pm

Yes, I think so, since I didn't get the error on my desktop or my player's laptop.
The World of Farland: www.farlandworld.com

The best PbP site on the net: www.myth-weavers.com

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Sat Dec 02, 2006 5:54 am

Farland wrote::shock:

Damn, guys, cut me some slack here. I DO know how to reveal hidden files and folders in windows. I really am not too bad with a computer.

:D
Ha, I wasn't paying attention to who heruca was talking to, I just added the clarification out of habit :P

I get a dozen questions like that per day over IMs heheheh.

Locked

Who is online

Users browsing this forum: No registered users and 2 guests