Page 1 of 1

Usability: Animations (1.02b) [Known Limitation]

Posted: Mon Dec 18, 2006 12:14 pm
by Farland
I don't know how big of a bug this is, but I tried to place the lit campfire and it didn't appear on the map. I then tried to place it again using the same name, and I got the message that I had to choose a different name, so apparently the campfire is somewhere but invisible. Is it behind the main map?

Edit: If I then go to the unit manager and select the eye, it appears. Strange. Not a big deal, but strange. It's the same deal with the light glow.

Posted: Mon Dec 18, 2006 12:35 pm
by heruca
Sounds like you used the "Campfire, Lit" animation, which for technical reasons I had to make invisible by default (because Objects default to hidden status when deployed, and the animation won't allow for the 50% transparency preview). The same issue happens with other pre-compiled animations, such as the light glow. I'll eventually find a better way to deal with these, because I realize it can be confusing.

Posted: Mon Dec 18, 2006 3:22 pm
by Farland
Okay, so it's not an issue. Just checking. Yeah, some other way of doing it might be better, but it's not a big deal.