Page 1 of 4

Attention Mac users!

Posted: Fri Jun 18, 2010 7:26 pm
by heruca
I just started having a serious problem with Battlegrounds after installing the latest Security Patch for Mac OS X. Now, every time I launch ANY version of BRPG, I get the error shown in the attached pic, and regardless of which button I press, BRPG fails to launch.

I was wondering if any other Mac OS X users reading this have already installed the latest security patch? If so, are you having the same problem when trying to launch BRPG, or is this only happening to me? I'm going to see if I can restore my computer to it's prior state before applying the security patch.

I am running Mac OS X v10.5.8, btw.

Posted: Fri Jun 18, 2010 7:49 pm
by heruca
Whew! Got BRPG working again by restoring the three files shown highlighted below. The location to where these reside is also shown (in the popup menu).

However, if this latest security patch from Apple is going to "break" BRPG for all Mac OS X users, I'm in for a world of hurt.

Posted: Fri Jun 18, 2010 9:13 pm
by Omnidon
Yeah Adobe broke one of my favorite point-and-click adventure games the same way a long time ago.

Whenever I try to launch that game it complains that it can't find Quicktime, because it was designed for an older version of Quicktime and Adobe had changed the directory structure of the new version.
heruca wrote:However, if this latest security patch from Apple is going to "break" BRPG for all Mac OS X users, I'm in for a world of hurt.
Any info in the patch notes about how you might make BG compatible with the new version?
Or any news from Adobe about it?

Posted: Fri Jun 18, 2010 11:04 pm
by heruca
Omnidon wrote:Any info in the patch notes about how you might make BG compatible with the new version?
Or any news from Adobe about it?
I did a few google searches and came up blank. I'll try again in a few days. If this affects all Director MX-based apps that use an "Xtras" folder, I suspect someone will find a better fix eventually. Completely self-contained apps (those that don't use an "Xtras" folder) don't seem to be affected by the latest OS X security update.

In the meantime, if anyone needs the older Macromedia/Shockwave files, let me know and I can send them via email, or post them here on the forums.

Please post mac files

Posted: Tue Jun 29, 2010 8:53 am
by markuwp
heruca wrote: In the meantime, if anyone needs the older Macromedia/Shockwave files, let me know and I can send them via email, or post them here on the forums.
Can you please post the older files that still work with BRPG? I use a PC, but a couple of my players are on Macs and having trouble. Thanks.


Posted: Tue Jun 29, 2010 12:08 pm
by heruca
Here you go. Point your players to this thread so they can see where these files need to be placed.

Posted: Tue Jun 29, 2010 2:27 pm
by Omnidon
Bumped this up to a Global Announcement.


Posted: Wed Jun 30, 2010 9:23 am
by Badblade
Is Battlegrounds going to be adapted to this issue? My gamers... aren't the most technically savvy. Having to start recovering Shockwave files and so on... is probably going to be the death of Battlegrounds for us. :(

Posted: Wed Jun 30, 2010 10:22 am
by heruca
I'm afraid I don't know the answer to that yet. It's possible that a future security update will fix this, but I'm not holding my breath.

One of the things I've always liked about Battlegrounds was the simplicity of installing it; just unzip the download and you're ready to go (i.e., no need for additional frameworks like Java, Python, or .NET). So you can imagine that I'm less than thrilled with this development.

The more information that users post here the better. Perhaps this issue only affects a small minority of users. Perhaps only certain OS X versions are affected. Perhaps future versions of OS X won't be affected.

I've noticed that Director-created apps that don't use an external Xtras folder still run fine even after installing the security update, so it's possible that I can get around this issue by repackaging BRPG in such a way that it doesn't use an external Xtras folder.

Shockwave Files

Posted: Tue Jul 27, 2010 3:07 pm
by badblade
I take it there is still no resolution? I can't get the software working at all on my Mac.

I have tried downloading those Shockwave files, but I can't seem to figure out where they go. The image above looks like it may be from an older OS. I have pasted them all over the place, but I just keep getting the same error.

Help! :(

Re: Shockwave Files

Posted: Tue Jul 27, 2010 3:10 pm
by heruca
badblade wrote:The image above looks like it may be from an older OS.
The image was taken while running Mac OS X v10.5.8.

What version are you running? Snow Leopard?

The above-mentioned fix is the only solution I ma currently aware of. It will probably work for you, if we can figure out exactly where the files need to go.

Search your computer for a folder or folders called "Macromedia" or "Shockwave 10". That should give you a good starting point in your search for the correct location.

Posted: Tue Jul 27, 2010 3:37 pm
by heruca
And if that fails, try this and let me know if that is a working solution.

No luck

Posted: Wed Aug 25, 2010 9:17 am
by Badblade
Hey Heruca,

Both of those solutions failed. Using 10.5.8, and I did the full install. I wish I were more of a tech-nerd... I have no idea what to try next.

Posted: Wed Aug 25, 2010 9:41 am
by heruca
Welcome, Badblade.

After BRPG v1.6i is released (probably tomorrow), I will see if I can compile a new BRPG executable for the Mac that has the Xtras folder embedded within it. That should address the problem.

Posted: Wed Aug 25, 2010 10:27 am
by heruca
Actually, scratch that. I decided to take a stab at this right away, since I will need to find a fix to this issue that works for ALL Mac users.

Download the attached file, unzip it, and place it in your BRPG folder, overwriting the original BRPG executable/app. Then delete your Xtras folder (or move it someplace else for safekeeping, should you need it again).

Let me know if it works, as I have no way of testing it (other than ensuring it launches).

Posted: Wed Sep 01, 2010 10:55 pm
by heruca
Could one of the four people who have already downloaded this file let me know if it works or not?

New file

Posted: Sun Sep 05, 2010 4:28 pm
by vain
That seems to have made things worse. Now it says it needs Shockwave 8.5


Been digging at this a bit, when attempting to open BRPG I get the following error on the console in addition to the shockwave error:

9/5/10 16:49:02 Battlegrounds RPG Edition[3678] GetDiskFragment returns -2804 for <PluginLib><PluginLib><MacromediaRuntimeLib><> when trying to load /Library/Application Support//Macromedia/Shockwave 10/Shockwave.bundle/Contents/MacOS/PluginLib

Although the double slash shouldn't pose a problem, that might be something to try fixing. And this might be helpful in decoding the error a bit: ... 00184.html

Sorry, I know nothing about developing with shockwave, so I'm just trying to give everything I can find that might be useful here. Will update if I find more.

Posted: Sun Sep 05, 2010 10:19 pm
by heruca
Welcome, vain.

Thanks for the info. I'm not sure if it will help me much in figuring out a fix, but I'll look into it.

Can I assume you went straight for the second fix (the new executable with self-contained Xtras) and never tried the first fix? I don't recommend trying both fixes; choose one or the other.

Posted: Mon Sep 06, 2010 1:32 am
by vain
Never tried the first fix, attempted the new executable, got error about needing shockwave 8.5 and reverted to the original executable. Attempted the full install of shockwave player both 32 and 64 bit, no joy. Attempted permissions repair (and also manually checked permissions) no joy.

For what its worth, the most current version of Shockwave for the mac is version 11, which now resides in /Library/Application Support/Adobe/
(hooray for corporate buyouts!).

In addition to not being a 32 bit carbon app anymore, the directory structure inside the plugin bundle is significantly altered. As an aside, tricking the app to look in the shockwave 11 bundle via some symlinks still produces the same "requires shockwave" error, but not the console error.

As a programmer myself, I know how much work a statement like this entails, but perhaps the long term (or even only) viable solution is to build convert to and build against the shockwave 11 plugin. Alternatively, you could drop shockwave all together, but I'm betting you're not the type of person to do low level rewrites for fun :wink:


After rereading my post, I realized I had been installing and uninstalling shockwave 11, not 10. So I grabbed the full install of 10 from adobe's website and installed it (verifying that it does indeed install to /Library/Application Support/Macromedia). Unfortunately I am sad to report no change in behavior.

Posted: Mon Sep 06, 2010 10:00 am
by heruca
Hmm, I was about to recommend doing an uninstall of Shockwave Player 11 and then installing the Full Install of Shockwave Player 10 for PPC (quit all open browsers before this step). But it sounds like you may already have done this and it didn't help. :(

This would be for using the original executable that comes with BRPG (and the Xtras folder), not the executable I posted above.

Posted: Mon Sep 06, 2010 12:47 pm
by vain
I am pleased to announce some success!

After uninstalling shockwave 10, this time I proceeded to delete the entire /Library/Application Support/Macromedia directory and all files in it and re-installed from the full shockwave 10 installer. The result of this is a 100% clean shockwave installation and interestingly an installation with different permissions. Where as previously the contents of the shockwave directory were rwxrwxr-x root:admin the new contents are almost all rwxr-xr-x vain:vain. BRPG loads and throws no errors to the console. It appears that whatever the uninstall process does and the install process it's not the same as delete and re-install. This seems like a quick and easy fix that should work if someone else wants to test it.

If this does work for others, it may be the fix to use until a new version built against shockwave 11 can be made. If this does work for others, I can probably scrap together a little script to do the deletions for folks non-technical players and bundle the installer with it.


Forgot to mention, this worked with a vanilla install of BRPG1.6i, not the new modified executable.

Posted: Mon Sep 06, 2010 2:03 pm
by heruca
Excellent! Vain's efforts were not in vain, LOL! :lol:

If others report similar success, we can see about somehow automating the process for the less-technically inclined.

Posted: Wed Oct 27, 2010 11:49 pm
by tenkar
my mac osx knowledge is close to nil - trying to ween myself off my PC has become painful it seems

has there been an automated patch for this yet? or a walk thru for the mac newbs? ;)

Posted: Wed Oct 27, 2010 11:58 pm
by heruca
I'm afraid there is no automated patch for this issue yet. I gather you are experiencing a failure to launch? What version of Mac OS X are you running?

Posted: Sat Oct 30, 2010 11:43 am
by heruca
Last night I installed Snow Leopard (Mac OS X v10.6) for the first time. The only customization I did of the installation is to enable the checkbox for installing Rosetta, since BRPG requires Rosetta to run on Intel-based Macs, and Rosetta is disabled by default in the Snow Leopard installation.

After rebooting, I was running v10.6, with no additional updates installed yet. BRPG launched and ran fine. So I installed the first batch of updates presented by Apple's "Software Update..." app. After a reboot, BRPG still launched and ran fine.

Ran "Software Update..." again and was presented with the additional updates shown in the screenshot below. I installed all except for "Security Update 2010-006" (I was trying to isolate which Security Update was responsible for "breaking" BRPG). Rebooted, BRPG launched and ran fine.

So I went a head and installed "Security Update 2010-006", figuring for sure this would be the culprit. Nope. After rebooting, BRPG launched and ran fine.

I was now running Mac OS X v10.6.4, by the way. I tried a couple of other things to try and get BRPG to not work, as had happened before for me in OS X v10.5.8. I installed Flash Player 10 (or whatever the latest release is) and Shockwave Player 11. BRPG still worked fine.

So I'm left wondering if perhaps installing Rosetta was the only deciding factor. Anyone who already has Snow Leopard installed without Rosetta can easily install it after the fact. The Snow Leopard installer DVD may be required, and I don't think a reboot is even necessary afterwards.

Note that I never had to bother with any of the workarounds presented earlier in this thread. BRPG simply worked, and I was unable to get it to break regardless of what I installed.

I hope this info is useful to someone, although I have to confess it leaves me a bit baffled.