Page 1 of 1

Mouse wheel causing client crash

Posted: Sun Jun 12, 2011 2:28 am
by ThinIzzy
Using the mouse wheel to rotate a figure in version 1.7 causes my client to crash. Using Windows 7 Home Premium for my OS.

Posted: Sun Jun 12, 2011 4:08 am
by TRIAD4Evr
Happened to me, too, on the GM end... which is how we then revealed the license issue being still in play, too. Seems rotating with the mouse wheel still has problems! This was while I was using the GM client and Izzy was using his own licensed player client.

Posted: Sun Jun 12, 2011 10:43 am
by heruca
TRIAD4Evr wrote:Seems rotating with the mouse wheel still has problems!
Gah! I thought this was fixed a long time ago. Did it just start happening again in recent releases, or was it never truly fixed?

Posted: Sun Jun 12, 2011 2:55 pm
by TRIAD4Evr
It seemed to go away for a bit but I recall maybe one release after you listed that as fixed it happened again for me, but it's so random when it appears in the first place I'm not sure it ever went away. Any chance to add a keybind for rotate figure left, rotate figure right as a workaround? It happens often enough that I see it almost once a session on my own end as the GM, possibly more, and that's too often...

Posted: Sun Jun 12, 2011 3:01 pm
by heruca
TRIAD4Evr wrote:Any chance to add a keybind for rotate figure left, rotate figure right as a workaround?
Use the "+" and "-" keys to rotate a selected unit/s, instead of the mousewheel.

Posted: Sun Jun 12, 2011 4:30 pm
by ThinIzzy
heruca wrote:
TRIAD4Evr wrote:Any chance to add a keybind for rotate figure left, rotate figure right as a workaround?
Use the "+" and "-" keys to rotate a selected unit/s, instead of the mousewheel.
Cool beans - good to know. Thanks!

Posted: Sun Jun 12, 2011 6:36 pm
by Kazander
heruca wrote:Gah! I thought this was fixed a long time ago. Did it just start happening again in recent releases, or was it never truly fixed?
FYI, I'm not using 1.7b yet, but from when you declared it fixed through 1.7a I have not had this problem reappear.

Posted: Tue Jun 21, 2011 1:42 am
by TRIAD4Evr
It became less common for me but still happens at least once a session. Any word on this one?

Posted: Tue Jun 21, 2011 2:17 am
by heruca
See my prior post in this thread.

Posted: Tue Jun 21, 2011 10:11 am
by TRIAD4Evr
I saw the workaround- I was just wondering if any further information was available or if you had been able to reproduce this...

Posted: Tue Jul 05, 2011 10:29 am
by heruca
I have not been able to reproduce this, so for BRPG v1.7c I have added an option to disable rotation of units via the mousewheel. Users who have been crashing due to this bug should enable this option to avoid the bug/crash.

Consider this a stopgap measure until such a time as I can reproduce the bug and find a permanent fix.

Posted: Wed Jul 13, 2011 8:16 pm
by TRIAD4Evr
Well that's a start! It's funny, for me up until now, it happened _every_ session at least once until my last session where I started using the keys to rotate. Still, one of my gamers managed to crash that way and had to reconnect! Must be something wrong on my end...

Posted: Thu Sep 08, 2011 12:22 am
by heruca
In BRPG v1.7c, if you lock up after rotating a unit with the mousewheel, try pressing the CapsLock key. It might help get you out of an endless loop. I forgot to mention this when v1.7c was first released. And please let me know if this tip worked or not.

Posted: Thu Sep 08, 2011 12:24 am
by TRIAD4Evr
Usually it immediately crashes to desktop, I never get the chance to hit anything.