FOW reveal shifting

Help improve BRPG and BGE by reporting any bugs you encounter.
Mark
Soldier
Posts: 11
Joined: Mon Feb 19, 2007 2:56 pm

FOW reveal shifting

Post by Mark » Sat Jul 30, 2011 8:54 pm

I'm running BG1.6 on a Intel core 2 Duo MacBook Pro. When I reveal a section in FOW, the actual revealed area shifts a few feet up to the left after of the selected one. It happens with all reveals modes. Any ideas?

Mark

User avatar
heruca
Developer
Posts: 9324
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sat Jul 30, 2011 11:33 pm

Are you using map offsets? Does changing the zoom level make the issue go away? Does it continue to happen even after re-launching BRPG?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Mark
Soldier
Posts: 11
Joined: Mon Feb 19, 2007 2:56 pm

Post by Mark » Sat Jul 30, 2011 11:50 pm

heruca wrote:Are you using map offsets? Does changing the zoom level make the issue go away? Does it continue to happen even after re-launching BRPG?
Yes, using offsets, but same problem when I remove them. Same problem on reboot and zoom. But when reducing Fractional Cell Height the bug goes away....

User avatar
heruca
Developer
Posts: 9324
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Sun Jul 31, 2011 1:20 pm

Mark wrote:But when reducing Fractional Cell Height the bug goes away
Great, now I know exactly where to look for the bug. Thanks.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Paul
Cannon Fodder
Posts: 2
Joined: Wed Aug 31, 2011 8:49 am

I have a similar problem

Post by Paul » Wed Aug 31, 2011 9:00 am

I've noticed a problem where I bring maps with existing grid overlays into Battlegrounds. If you use the vertical and horizontal offsets to line up your map it will then throw out the FOW by the same amount when you are doing manual reveals. I've proved this by taking the same map into Battlegrounds and not using the offsets. The FOW then works fine, but of course you have two sets of gridlines on your map. I'm currently using 1.7c but it also existed in 1.6m.

User avatar
heruca
Developer
Posts: 9324
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Wed Aug 31, 2011 9:40 am

Welcome, Paul.

Thanks for the bug report. You were not using fractional cell widths, correct? So I guess that is two different issues that need fixing.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Paul
Cannon Fodder
Posts: 2
Joined: Wed Aug 31, 2011 8:49 am

FOW Reveal shifting

Post by Paul » Wed Aug 31, 2011 5:41 pm

No, I can confirm I wasn't using fractional cell widths. The problem also only happens when you import a map, adjust the offsets, save it as part of an encounter, close it, then re-load the encounter and turn on FOW. I hope this helps you find the problem.

Motdc
Captain
Posts: 84
Joined: Wed Mar 11, 2009 8:57 am
Location: Connecticut, USA
Contact:

Post by Motdc » Fri Oct 19, 2012 11:14 am

I am experiencing a similar problem with teh FOW. The area (and I think the proportion) being revealed is offset. I tried a couple of different zoom modes but could not get it to work.

User avatar
heruca
Developer
Posts: 9324
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Oct 19, 2012 11:18 am

Are you using map offsets? If so, does setting them back to 0, 0 fix the problem?

Are you using a fractional cell width and/or height?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Motdc
Captain
Posts: 84
Joined: Wed Mar 11, 2009 8:57 am
Location: Connecticut, USA
Contact:

Post by Motdc » Fri Oct 19, 2012 11:36 am

I did have a very minor map offset. I removed it and the FoW works now.

BradN
Cannon Fodder
Posts: 7
Joined: Thu Nov 15, 2012 8:17 pm

Post by BradN » Thu Nov 15, 2012 8:27 pm

I'm having the same issue. Maps I created in Dunjinni, exported to BMP with 61 pixels per square and then converted to PNGs. They already have the grids on them and I have to adjust everything to get it to line up correctly, but then FOW appears to the left and above where I select.

BradN

User avatar
heruca
Developer
Posts: 9324
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Nov 15, 2012 10:45 pm

Welcome, BradN.

For maps which you intend to use with the Fog of War feature, I suggest you crop it in an image editor such that a grid cell begins in the extreme upper left. Don't forget to purge you original map prior to bringing the cropped map back into BRPG, if you use the same filename on the cropped version.

At some point, I will need to update the Fog of War feature to account for the map offset feature, which was added later.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9324
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Nov 16, 2012 6:15 pm

Update: In BRPG v1.8a, you will be able to use the map offset feature in conjunction with the Fog of War feature. The Fog of War Reveal and Conceal tools now draw in the right place when you release the mouse. :)

I think I also fixed a bug that caused the Fog of War layer to not be aligned with the map on the GM's display when you first load an Encounter. The problem would go away as soon as you scrolled or zoomed the map, but now it won't manifest in the first place.
Last edited by heruca on Fri Nov 16, 2012 6:29 pm, edited 2 times in total.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Motdc
Captain
Posts: 84
Joined: Wed Mar 11, 2009 8:57 am
Location: Connecticut, USA
Contact:

Post by Motdc » Fri Nov 16, 2012 6:26 pm

Yeah! Looking forward to using it.

Post Reply