Page 1 of 1

Viewing the User Manual

Posted: Sun Sep 08, 2013 7:06 pm
by Mr Crumbly
Hi,

I'm attempting to get access to the BGE user manual from within the program. I'm running Windows 7 and use Foxit Reader for PDFs. I set up a shortcut to Foxit Reader inside the BGE root folder and renamed it PDF Viewer. I then opened BGE and selected User Manual off the Battlegrounds button but nothing happened. I'm using beta version 1.5 of the program.

Any pointers as to what I'm doing wrong? It's driving me nuts!

Regards,

Alan

Posted: Mon Sep 09, 2013 12:09 am
by Omnidon
Yeah, I seem to be getting the same effect in my old 1.3 BGE.
Haven't downloaded 1.5 yet. You do mean "shortcut" (.lnk file) when you say "alias" in the user manual right heruca?

Posted: Mon Sep 09, 2013 9:08 am
by heruca
Yes, Omnidon, that is what I meant.

Not sure why this isn't working, but have you tried placing a copy of the actual PDF program in the BGE directory?

Posted: Mon Sep 09, 2013 4:45 pm
by Mr Crumbly
I use Foxit Reader which needs to be fully installed, so I can't move just the executable file into the Battlegrounds folder. I have tried it with another more portable PDF reader and it finds the program as long as you name the executable file PDF Viewer.exe, but it only shows the program start screen - it doesn't automatically load the User Manual in (which I had presumed it would do).

I tried it again with the Foxit Reader shortcut renamed to PDF Viewer.exe rather than just PDF Viewer but it still didn't work.

Hope this helps.

Regards,

Alan

Posted: Mon Sep 09, 2013 4:54 pm
by heruca
I downloaded and installed FoxIt Reader, and had similarly disappointing results. In fact, I couldn't get it to work with Acrobat Reader, either.

I know for a fact that this feature used to work, but perhaps it broke in more recent releases of Windows. Or perhaps it is related to security settings, such as UAC. Need to investigate this further.

Posted: Mon Sep 09, 2013 6:28 pm
by Omnidon
I always keep UAC disabled on all my PCs. (It's a completely useless feature on a PC with only one user.)
Haven't done any additional testing yet though. I've never tested that feature in the past so I have no idea how long it has been broken.

Posted: Mon Sep 09, 2013 6:43 pm
by heruca
I think I may have found a workaround: Try replacing any spaces in the BGE directory name with underscores. For example "BGE v1_5 Win" should be renamed "BGE_v1_5_Win". And if that alone doesn't work, rename "BGE User Manual.pdf" to "BGE_User_Manual.pdf".

Posted: Mon Sep 09, 2013 6:54 pm
by heruca
I think this may be more an issue of Foxit Reader not liking spaces in filenames and filepaths, rather than an issue with BGE/Adobe Director, but it's hard to be certain, since the command is failing silently and not returning any sort of error code.

Posted: Mon Sep 09, 2013 7:04 pm
by Mr Crumbly
This didn't work for me. Did it work with a Foxit Reader shortcut in the BGE folder or was an Acrobat shortcut?

Regards,

Alan

Posted: Tue Sep 10, 2013 12:26 am
by Omnidon
My PDF viewer is Google Chrome, not foxit.

Posted: Tue Sep 10, 2013 9:42 am
by heruca
I made it work with a shortcut to Foxit Reader. I guess it won't work for you until I roll out some code changes in BGE v1.6.