Issue With Aliens Board Game and BGE 1.7

Virtual tabletop software specifically designed for boardgames, wargames, card games and dice games
Post Reply
ZenMonkey11
Sergeant
Posts: 44
Joined: Thu May 10, 2012 4:30 am

Issue With Aliens Board Game and BGE 1.7

Post by ZenMonkey11 » Tue Mar 08, 2016 11:21 pm

For some reason I can't get Aliens The Board Game to work right on the BGE 1.6 patch or the full version of BGE 1.7. It works on 1.5 just fine, but the other 2 versions have weird things happen, like when you move pieces on the map the mouse pointer isn't directly on it, and some of the portraits for the marines are missing, you can't rotate pieces either, and sometimes they don't high light if you select them.

I think who ever made the Aliens Mod, they should make a new one for version 1.7.

User avatar
heruca
Developer
Posts: 9361
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: Issue With Aliens Board Game and BGE 1.7

Post by heruca » Tue Mar 08, 2016 11:38 pm

Very odd. I'll try it out again. Thanks for letting me know something's possibly broken. Will report my findings.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9361
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: Issue With Aliens Board Game and BGE 1.7

Post by heruca » Tue Mar 08, 2016 11:46 pm

Seems to be working fine, here, in v1.7.

Have you tried rebooting your PC, then relaunching BGE?
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

ZenMonkey11
Sergeant
Posts: 44
Joined: Thu May 10, 2012 4:30 am

Re: Issue With Aliens Board Game and BGE 1.7

Post by ZenMonkey11 » Wed Mar 09, 2016 3:20 am

heruca wrote:Seems to be working fine, here, in v1.7.

Have you tried rebooting your PC, then relaunching BGE?
Oh I've done all of that. Reboots and fresh installs, the works. I've had this issue since last year, it's not anything new. I just stopped trying to get it to work with the 1.6 patch. This month I just found out there was a 1.7 version, so I installed it into 1.7 hoping that what ever it was, it would be fixed, but 1.7 seems to be more bugged then the 1.6 patch. Also if it helps you out any, I haven't tweaked anything on my end, everything is set to it's default settings.

User avatar
heruca
Developer
Posts: 9361
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: Issue With Aliens Board Game and BGE 1.7

Post by heruca » Wed Mar 09, 2016 10:14 am

Do you by chance have another computer you can install BGE on for testing purposes? I can give you a temporary license for it. I wan't to confirm that the software works, just not on your primary computer, for some reason. Once that's done, we can troubleshoot your main computer to see what could be causing this odd behavior.

I just played a complete game of Aliens without a single hitch, glitch, or error message, and units were easily draggable and selectable as intended, without any odd displacement/offset.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

ZenMonkey11
Sergeant
Posts: 44
Joined: Thu May 10, 2012 4:30 am

Re: Issue With Aliens Board Game and BGE 1.7

Post by ZenMonkey11 » Wed Mar 09, 2016 5:08 pm

heruca wrote:Do you by chance have another computer you can install BGE on for testing purposes? I can give you a temporary license for it. I wan't to confirm that the software works, just not on your primary computer, for some reason. Once that's done, we can troubleshoot your main computer to see what could be causing this odd behavior.

I just played a complete game of Aliens without a single hitch, glitch, or error message, and units were easily draggable and selectable as intended, without any odd displacement/offset.
That's so weird. You've tried The Aliens Board Game right, not the card game?

I do have one other computer but it's 9 years old and it only runs Linux. I have 2 Hard Drives in my current PC, I've been using BGE in Win 10, maybe I should try it in Win 7, if there isn't a Linux version of BGE?

ZenMonkey11
Sergeant
Posts: 44
Joined: Thu May 10, 2012 4:30 am

Re: Issue With Aliens Board Game and BGE 1.7

Post by ZenMonkey11 » Wed Mar 09, 2016 5:25 pm

I just logged on to win 7, I used the 1.6 patched version and the game has the same bugs. One thing I noticed was it seems to lag (Win 7 has a little rotating circle that appears on the mouse pointer when something is loading). I have the Intruder Board Game and it runs fine on all versions of BGE, no lag or issues on Win 7 or Win 10.

User avatar
heruca
Developer
Posts: 9361
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: Issue With Aliens Board Game and BGE 1.7

Post by heruca » Wed Mar 09, 2016 6:31 pm

Yeah, I played the boardgame, not the card game.

There's no Linux version of BGE (or BRPG), I'm afraid.

Is there some sort of "compatability mode" you can enable in Windows? If so, that's worth a shot.

I can't think why this game would lag more than Intruder. If anything, there's probably LESS components in Aliens.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

ZenMonkey11
Sergeant
Posts: 44
Joined: Thu May 10, 2012 4:30 am

Re: Issue With Aliens Board Game and BGE 1.7

Post by ZenMonkey11 » Thu Mar 10, 2016 12:05 am

OK so here what I did so far. I did a fresh install on Win 10. I set the compatibility to windows 8.1. This time I just added the base game not the variant. First I got an error message that read "Property Not Found, #memberNum, Script Error Continue?" I selected No. I opened it again and everything loaded fine. The lag seems to be gone too. So I don't know if the issues is because I loaded the base game and variant together each time, or if its the compatibility mode I selected.

User avatar
heruca
Developer
Posts: 9361
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: Issue With Aliens Board Game and BGE 1.7

Post by heruca » Thu Mar 10, 2016 7:52 am

Compatabilty mode must have fixed it. I still don't like that you got an error. I guess now I need to test the variant for myself.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

ZenMonkey11
Sergeant
Posts: 44
Joined: Thu May 10, 2012 4:30 am

Re: Issue With Aliens Board Game and BGE 1.7

Post by ZenMonkey11 » Thu Mar 10, 2016 2:47 pm

OK so here is what I did, I deleted everything (BGE 1.7, Aliens Board Game, Aliens Variant). I opened a new BGE 1.7, then I installed just the base game, everything loaded fine, no errors, no bugs. Then I added the variant content with no errors or bugs. Then I deleted everything again. This time I added the base Aliens Game with the variant, then loaded them together, and I got one of the bugs (no portrait for one of the charters). So it seems like its when you load them together you get the issue. Also I never used compatibility mode, so it's not that.

User avatar
heruca
Developer
Posts: 9361
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: Issue With Aliens Board Game and BGE 1.7

Post by heruca » Thu Mar 10, 2016 4:52 pm

Emphasis is mine.
The ReadMe file for Aliens boardgame variant wrote:About this Aliens Boardgame Variant
This is a small expansion for the BRPG conversion of the Aliens boardgame. To use it, you must already have downloaded and installed the Aliens Boardgame Conversion for BRPG
:P
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Post Reply