Page 1 of 1

Transparency failure

Posted: Thu Jun 04, 2015 5:13 pm
by Zyr0
Hi !

I'm currently creating a custom art pack for a game I intended to play on this summer with some friends. But i'm having a minor issue : I can't make the background of my minis transparent. I tried absolutely everything : different format, removing the background on GIMP by several ways, doing so on Paint, coloring everything in white in both software etc... nothing worked. Yet I have a mini that I did before and it is indeed transparent and I can't remember how I did that.

Some help would be welcome, thanks in advance.

Re: Transparency failure

Posted: Thu Jun 04, 2015 9:52 pm
by heruca
Are you saving the images as PNGs with transparency? That's essential.

Re: Transparency failure

Posted: Thu Jun 04, 2015 11:04 pm
by Omnidon
And by that he means you should ensure that your export/save settings in your image editor are set to save transparency.
Even if it has a transparent background while editing, often the export settings default to having transparency disabled.

Re: Transparency failure

Posted: Thu Jun 04, 2015 11:41 pm
by heruca
I'm not proficient with Gimp, but I know it can do what you are trying to do with it. Try searching for video tutorials on YouTube (e.g. search for "Gimp transparency").

Re: Transparency failure

Posted: Fri Jun 05, 2015 8:51 am
by Zyr0
Oh yes that was the issue ! I wasn't exporting my files correctly, thanks for your support :D !
For people having the same issue as me, to make a transparent background in GIMP, this is the procedure :

PS : Make sure your image is in PNG format before doing anything.

-Add an Alpha channel in Layer/Transparency. (If the option is disabled, you already have one.)

-Select the background with the "By color select" tool in Tools/Selection tools.

-Click the "Color to Alpha" option in "Color".

Then, this is the part I was failing to execute :

-click File/Export as...

-Select your image

-Export and replace

-Quit GIMP

-Click "Discard changes".

And it's done.