Can't Host on Mac OS X over a wireless connection

Alarian
Cannon Fodder
Posts: 9
Joined: Sat Apr 22, 2006 1:44 pm
Location: Brainerd, MN

Can't Host on Mac OS X over a wireless connection

Post by Alarian » Thu Dec 06, 2007 8:09 pm

I have been playing around with BG off and on over the past year+ and decided to take a look at it again today and seem to be having a problem. I can't host a session.

I click on host a session, use the default settings and when I click "host", it just hangs for a while and then gives the following message: Connection Failed. Please check your settings.

I am using the Mac version and I'm running Leopard.

I'll also point out I have a PC on the desk next to me as well, and I can host from there fine and I can connect with no problems from my Mac to the PC. I just can't host from the Mac (which is my preferred system).

I have port forwarding set up on my router and that doesn't help.

Also, I have looked through all the can't connect related posts on the site and they either didn't apply to my problem or I had already tried what had been suggested.

Any suggestions would be greatly appreciated.

Alarian

User avatar
heruca
Developer
Posts: 9371
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Dec 06, 2007 8:12 pm

Does your Mac have "direct" internet access, or is it going through a proxy server?

Try holding down the SHIFT key while pressing on the "Host" button. That should enable some diagnostic messages. Then let me know your results.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
heruca
Developer
Posts: 9371
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Thu Dec 06, 2007 8:28 pm

Another question: Is your Mac connecting wirelessly?

Read this thread if you haven't already:
http://battlegroundsgames.com/forums/vi ... php?t=1001

Maybe something there will help.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Thu Dec 06, 2007 9:18 pm

Have you double-checked that the port-forwarding is set up correctly for the Mac?

Each computer is given a different internal IP address, so just because it works for the PC doesn't mean it will work for the Mac.

Also, AFAIK routers can only forward each port to a single computer in your network at one time, so you probably have to stop forwarding that port to your PC in order to forward it to your Mac.

Alarian
Cannon Fodder
Posts: 9
Joined: Sat Apr 22, 2006 1:44 pm
Location: Brainerd, MN

Post by Alarian » Thu Dec 06, 2007 9:39 pm

Heruca, Yes, the problem in the link you posted is what I'm having. When I hold down the shift key when I try and connect, I see -11 then -13 then "MUC not initialized Properly".

I have a 2 month old iMac on a wireless network. Connecting via wire isn't really possible as I had the wireless built into the house and the router is in a location without easy access to it. (seemed like a good idea at the time).

As to port forwarding, I have port forwarding set up on the Mac and thats not working, I don't have port forwarding set up on the PC and it works fine (Note it didn't work on the mac before I set up forwarding either). I've done quite a bit of port forwarding in the past with other programs, so I'm pretty confident it's set up correctly.

Any other info I can provide, just ask.

Alarian

Alarian
Cannon Fodder
Posts: 9
Joined: Sat Apr 22, 2006 1:44 pm
Location: Brainerd, MN

Post by Alarian » Thu Dec 06, 2007 9:52 pm

I guess I should also say that I am running version 1.1 of BG on both machines.

User avatar
heruca
Developer
Posts: 9371
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Dec 07, 2007 1:12 am

Have you tried temporarily disabling the software firewall on the Mac (assuming it's even on), to see if that allows you to host?

As long as you're running v1.1, you should probably go ahead and upgrade to v1.1a. It won't change anything in regards to hosting, but it does fix some other bugs, so you should still be better off than with v1.1.

I'll be able to investigate this wireless Mac hosting issue more now that I have a new Intel Mac to test with. I'll have to get back to you on what those error codes mean, exactly.

In the meantime, I suggest you disable any network protocols that you don't need, to see if that helps (e.g. Firewire networking, dial-up modems, etc.).

BTW, port forwarding should only affect whether other computers can connect to you or not. Even if you haven't configured port-forwarding correctly, it should not prevent you from hosting a game.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Alarian
Cannon Fodder
Posts: 9
Joined: Sat Apr 22, 2006 1:44 pm
Location: Brainerd, MN

Post by Alarian » Fri Dec 07, 2007 3:22 am

Yes I have the firewall turned off on the mac and I also enabled the DMZ on the router so it was totally open for a little while and it made no difference.

I also already have all you suggested disabled as I don't use any of it (checked to make sure).

Good luck on finding the problem. I'm a big fan of anything that can run on both the Mac and the PC. Makes it easier to find players.

Alarian.

User avatar
heruca
Developer
Posts: 9371
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Dec 07, 2007 8:35 am

I hope this isn't a general issue with Mac OS X 10.5 (Leopard).

Alarian, do you have access to another Mac that you could try hosting on, just as a test?

To all: Has anyone else been able to host BRPG games on Leopard? I've yet to get my hands on Leopard, so I haven't been able to test it for myself.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Post by Omnidon » Fri Dec 07, 2007 12:36 pm

heruca wrote:BTW, port forwarding should only affect whether other computers can connect to you or not. Even if you haven't configured port-forwarding correctly, it should not prevent you from hosting a game.
Ah, didn't realize he couldn't even start up the game.

Languagegeek
Cannon Fodder
Posts: 2
Joined: Wed Jun 18, 2008 6:38 pm

Post by Languagegeek » Fri Nov 21, 2008 12:19 pm

Is there a definitive solution to this intel Mac wireless problem? i.e. I can host a session if I’m connected directly to my router via an ethernet cable, but I cannot host wirelessly. It would be very helpful to be able to follow a simple, step-by-step list of what I need to do. Perhaps this list already exists, and I just haven’t found it.

Thanks,
Chris

User avatar
heruca
Developer
Posts: 9371
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Post by heruca » Fri Nov 21, 2008 1:01 pm

Turning off all network protocols other than Airport (e.g., Bluetooth, FireWire, Parallels, etc.) seems to be the solution to the issue of being unable to host wirelessly on a Mac (Intel or PPC-based). Perhaps it's also possible to re-order/prioritize the network protocols (via drag-and-drop) so that you can leave some of them on, if you really need them.

See the attached image for settings that should work.
Attachments
Wireless Config for Macs.jpg
Wireless Config for Macs.jpg (87.8 KiB) Viewed 8005 times
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Languagegeek
Cannon Fodder
Posts: 2
Joined: Wed Jun 18, 2008 6:38 pm

Post by Languagegeek » Sat Nov 22, 2008 11:50 pm

Thanks! For Leopard users, the Network preferences screen is somewhat different. For everything except AirPort, you have to highlight the item, click on the “cog” button at the bottom of the window, and choose “Make Service Inactive”. It sounds like the same result, just a different process.

The wireless hosting is now succeeding. Our party has not re-started the campaign via Battlegrounds. It was very successful, and the other players are very excited about the software, the DM especially!

Chris

Post Reply