Page 1 of 1

strange problem installing

Posted: Thu Jul 31, 2008 12:35 am
by Branwyn
I have a fairly new Mac Pro (with Intel) running OSX v10.5.4

I downloaded Battlegrounds version 1.2f, but I have problems running the program after unzipping. Whenever I try to launch it asks where it should find "MainMIAW.dir" If I point it at "MainMIAW.dxr" it asks:

Where is "Caviar 160GB Users:hernan:Desktop:GURPS Project:Battlegrounds RPG Editio#191D85:User Cast.cst"

So I pointed it to "User Cast.cxt" in my directory, and it asked for another file... I remapped several files this way until I get an error that says:

Director Player Error
This application requires an Xtra (Text) that either does not exist or failed to initialize properly. Please make sure the appropriate Xtras are in the Xtras folder(s).

I'm sure I downloaded the Mac file ( I don't have StuffIt loaded on my Mac, so whatever known error that is shouldn't be what I'm experiencing. It's been unzipping with OSX's ArchiveUtility.

I tried loading the v1.2g beta, but I'm experiencing the same problem.

I also tried unzipping the files using a completely different program, "The Unarchiver" with the same results.

Posted: Thu Jul 31, 2008 12:58 am
by heruca
Hi Branwyn.

Strange indeed. Are you always unzipping the same download, or have you tried downloading a fresh zip? It's possible something got corrupted the first time you downloaded BRPG.

Let's try a test to see if it's just a zip-related issue.

Download this and let me know if it launches OK for you: ... _v1_1b.dmg

Posted: Thu Jul 31, 2008 2:39 am
by Branwyn
I trashed the downloaded .zip file and the unzipped folder, and downloaded a new .zip file each time i tried something else new. I also tried fresh downloads into different folders on my hard drive. I always got the same errors.

The version you linked to appears to run just fine.

Posted: Thu Jul 31, 2008 3:08 am
by heruca
OK, then tomorrow I'll create a full v1.2g DMG file (I've been meaning to do that, anyway). I'll post a link here once it's done uploading.

I'd love to figure out what the unzipping problem is, though, so that I'll know the next time this comes up. Is anyone else here running BRPG under OS X Leopard?

Posted: Tue Sep 30, 2008 12:13 pm
by Corellion
I downloaded the "v1.2f Demo for Windows" today and have the same problem as described above:

- Start "Battlegrounds RPG Edition.exe"
- Where is "MainMIAW.dir"?
- There is no "MainMIAW.dir" so I also point to "MainMIAW.dxr"
- Director Player Error: This application requires an Xtra (Text) that either does not exist or failed to initialize properly. Please make sure the appropriate Xtras are in the Xtras folder(s).

Regards Corellion

Posted: Tue Sep 30, 2008 1:44 pm
by heruca
Welcome, Corellion.

Did you do an "Extract All" on the zip file? Sometimes, people make the mistake of browsing the zip file's contents and trying to launch the app without ever decompressing the zip.

Posted: Tue Sep 30, 2008 1:47 pm
by heruca
You may also want to try downloading v1.3c, and see if you get better results.

Posted: Wed Oct 01, 2008 2:42 am
by Corellion
I tried more versions: v1.3, v1.2g, v1.2f and an older version I downloaded last year 1.07.
And I tried decompressing the Zip-File in several alternatives.
But there is always the same problem...
I tried starting the programm on two different systems, but alwasy the same problem.

But it could be that this is not a problem of the zip-file,
yesterday I recognized that both systems were infected by the same virus and also infected the "Battlegrounds RPG Edition.exe".
After cleaning and repairing the systems over night I will try to start the programm this evening.

I will tell you about...

Posted: Thu Oct 02, 2008 4:25 am
by Corellion
Like I already assumed yesterday,
when i extracted the zip-archive, a Virus (W32.Polip) infected the "Battlegrounds RPG Edition.exe" and changed the size of the file.
This was the reason, for the errors during the start of the programm.

Posted: Thu Oct 02, 2008 11:42 am
by heruca
Thanks for getting back to us about the cause. Just to be perfectly clear, the virus doesn't come with the zip file, right? It only infects the EXE during unzipping on your system because you already have the virus?

Have you been able to use a virus scanner to clean out your system?

Posted: Wed Oct 08, 2008 2:02 am
by Corellion
Yes, that is right!
The virus infected the system before I unzipped the battlegrounds data.
During unzipping progress it infected the "Battlegrounds RPG Edition.exe".

Nearly all virus-scanners will identify the W32.Polip-Virus, but they want to delete the infected exe-files.
I searched the internet and found an enhanced stinger3 scanner from mcafee to repair W32.Polip-infected exe-files.
It repaired neraly 99% of the infected files.
Unfortunately some files are not produced correctly again, so you have to overwrite these files with original exe-files (in my case, less than 1% could not be repaired correctly).

Posted: Sat Jul 25, 2009 3:09 pm
by heruca
I'm hearing reports that there may be problems installing and running BRPG on Mac OS X v10.5 (aka Leopard). BRPG requires Rosetta to run in OS X, and some users apparently don't have Rosetta installed.

I will be purchasing and installing Leopard this weekend to test things out myself. In the meantime, if Rosetta is offered as an optional install on the OS X DVD, try installing it and see if that helps.

Does anyone know if the newest Intel-based Macs have dropped support for Rosetta? AFAIK, Rosetta will even be included in the forthcoming Snow Leopard OS (although there are rumors that Rosetta may be optional install in Snow Leopard).