All components and game boards load as question marks?

Post Reply
Jyornan
Cannon Fodder
Posts: 3
Joined: Sun Feb 15, 2015 8:51 pm

All components and game boards load as question marks?

Post by Jyornan » Sun Sep 18, 2016 6:31 pm

Hello, I recently came back to play a game that I created in BGE. When I load the game all components of the game are shown as a question mark? Help! Took me forever to create the game now its gone. other saved game boards have the same issue. Why is this happening?

all the components are in the component folder. I even copied them over to the art pack folder and did a refresh art pack command which did nothing.

Awhile back I purged the media folder... did that delete everything even in other saved boards? I currently have over ten game boards that all have the same issue.

What should I do? As I mentioned I have all the components in the components file.

User avatar
Omnidon
Site Admin
Posts: 2186
Joined: Mon Feb 06, 2006 7:46 pm
Location: NY State, USA
Contact:

Re: All components and game boards load as question marks?

Post by Omnidon » Sun Sep 18, 2016 7:59 pm

BGE's imported media is stored in a cast file located at: "\Support Files\User Media.cxt"

If you still have your old cast file, then just copy it over.

If you lost your old cast file, you can reimport your old files if you still have them by adding them to a blank encounter. If the file names are the same then your existing encounters should work again after the images are reimported.

There should be a Batch Import feature in the BGE menu that will allow you to import many minis at once.
(Make sure you're using 1.6 or 1.7 since it was broken in 1.5)

Jyornan
Cannon Fodder
Posts: 3
Joined: Sun Feb 15, 2015 8:51 pm

Re: All components and game boards load as question marks?

Post by Jyornan » Sun Sep 18, 2016 8:34 pm

Ah thank you! Batch Import did the trick. Game on!

User avatar
heruca
Developer
Posts: 9381
Joined: Sun Nov 20, 2005 11:58 pm
Location: Buenos Aires, Argentina
Contact:

Re: All components and game boards load as question marks?

Post by heruca » Mon Sep 19, 2016 3:06 pm

Thanks for fielding this, Omnidon.

Things have been so slow on the forums that I've started only checking them once or twice a day.

Jyornan, I suspect your purging of media is what caused the placeholder tokens to replace all your previously-imported content. Are you making these games just for yourself, or are you intending to distribute them to other players? You might want to watch this part of the BGE tutorial video to see how to export your media assets to a stand-alone file, for safekeeping, if not for distribution.
:arrow: Please help spread the word about BRPG and BGE, and never hesitate to tell me how I can make them better suit your gaming needs.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests